WordPress Maintenance Plan

Our service is WordPress updates and Plugin updates with security monitoring as a maintenance plan. We are a small team of WordPress professionals. We've developed and managed WordPress sites for over 10 years. Our service is focused on WordPress security. We actively monitor all our clients websites and are constantly adding new layers of security behind the scenes at no additional cost!

All Maintenance Plans Include

WordPress Hardening

Industry standard WordPress hardening and our special security features as a bonus.

Automated Backups

Setup an automated backup system for a fail safe version of your WordPress installation.

Keep Up-To-Date

Monthly WordPress core and Plugin updates, with human inspection afterwards.

24/7 Monitoring

Up time monitoring that notifies our team to detect any server issues.

WordPress Maintenance Pricing

Basic

$50/month

Montly Maintenance

  • WordPress Hardening
  • Automated Backups
  • Keep Up-to-Date
  • 24/7 Uptime Monitoring
Popular Choice
Premium

$135/month

Basic with 1 Content Edit

  • WordPress Hardening
  • Automated Backups
  • Keep Up-to-Date
  • 24/7 Uptime Monitoring
Ecommerce

$299/month

Basic & WooCommerce Updates

  • WordPress Hardening
  • Automated Backups
  • Keep Up-to-Date
  • 24/7 Uptime Monitoring

*All maintenance plans are byos (bring your own server). Price may vary depending on amount of plugins and if using a page builder.

Stand Alone Services

Hack Cleanup

Website been hacked? We offer cleanup services to get your site back to a clean version. Whether it's a restore from a backup or full on file cleaning. Prices vary based on what type of hack has occured and the size of your website. Prices starting at $250.

Active Scan

Get a complete report on your current website's security status. Our active scan reports back any known vulnerabilites with your current WordPress installation.

WordPress Hardening

Industry standard WordPress hardening with advanced security features we've created over years of WordPress management as an added bonus.

Users Password Audit

We will scan your password hashes to see if your users are using strong passwords or not. A one time scan to compare against know wordlists on the web and dark net.

Latest Vulnerable Plugins

CRM Perks Forms

<= 1.1.0 - Reflected Cross-Site Scripting (XSS) vulnerability

Fixed: N/A

Plugin URL

WZone – Lite Version

<= 3.1 Lite - Cross-Site Request Forgery (CSRF) vulnerability

Fixed: N/A

Plugin URL

Media Library Folders

<= 7.1.1 - Cross-Site Request Forgery (CSRF) vulnerability

Fixed: N/A

Plugin URL

OSM – OpenStreetMap

<= 6.0 - Cross-Site Request Forgery (CSRF) vulnerability

Fixed: N/A

Plugin URL

Forym

<= 1.5.8 - Reflected Cross-Site Scripting (XSS) vulnerability

Fixed: N/A

Plugin URL

3dady real-time web stats

<= 1.0 - Stored Cross-Site Scripting (XSS) via Cross-Site Request Forgery (CSRF) vulnerability

Fixed: N/A

Plugin URL

Contact Bank

<= 3.0.30 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability

Fixed: N/A

Plugin URL

LBstopattack

<= 1.1.2 - Cross-Site Request Forgery (CSRF) vulnerability

Fixed: N/A

Plugin URL

HREFLANG Tags Lite

<= 2.0.0 - Unauthenticated Plugin Data Reset vulnerability

Fixed: N/A

Plugin URL

Profile Builder

<= 3.6.0 - Cross-Site Request Forgery (CSRF) vulnerability

Fixed: 3.6.1

Plugin URL

Redirection for Contact Form 7

<= 2.4.0 - Unauthenticated Options Change vulnerability

Fixed: 2.6.0

Plugin URL

Accordions

<= 2.0.3 - Authenticated WordPress Options Change vulnerability

Fixed: 2.1.0

Plugin URL

Analytics Cat

<= 1.0.9 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability

Fixed: 1.1.0

Plugin URL

Quiz And Survey Master

<= 7.3.4 - Insecure direct object references (IDOR) vulnerability

Fixed: 7.3.5

Plugin URL

Analytify

<= 4.2.2 - Cross-Site Request Forgery (CSRF) vulnerability

Fixed: 4.2.3

Plugin URL

Media Library Assistant

<= 3.00 - Unauthenticated Error Log Disclosure vulnerability

Fixed: 3.01

Plugin URL

AdminPad

<= 2.1 - Cross-Site Request Forgery (CSRF) vulnerability

Fixed: 2.2

Plugin URL

Asset CleanUp: Page Speed Booster

<= 1.3.8.4 - Authenticated Reflected Cross-Site Scripting (XSS) vulnerability

Fixed: 1.3.8.5

Plugin URL

Store Locator WordPress

<= 1.4.5 - Cross-Site Scripting (XSS) via Cross-Site Request Forgery (CSRF) vulnerability

Fixed: N/A

Plugin URL

iQ Block Country

<= 1.2.18 - Block BYPASS vulnerability

Fixed: 1.2.19

Plugin URL
17250 Dallas Pkwy Suite 62, Dallas, TX 75248